We have moved to GitHub Issues
Created by Niels Hartvig 01 Aug 2017, 13:22:53 Updated by Shannon Deminick 02 Aug 2017, 02:30:28Tags: Unscheduled
Subtask of: UAASSCRUM-964
While a blueprint might make sense when explained, it does require an explanation and until then it causes the editor to puzzle. Instead we should look at how the Blueprint feature will be used which is very similar to how "Templates" are used in word processors (ie. "Product Landingpage", "Testimonial Blogpost", etc).
After talking to a couple of editors, it's clear that simply calling the feature "Content Templates" make much more sense (although it might confuse designers and developers a little bit as they're used to "Templates" being used for other things as well).
However, in this case we should accept that confusion and rename the feature from "Content Blueprints" to "Content Templates".
I've updated the design for the intro page and some wording. I'll merge this in.
I've thought more about changing the wording of 'blueprint' inside of the APIs and on further thought, if we do change it i think the API names will become very confusing since we have several places already in class/method names that have both Content and Template in them. Sticking to the term Blueprints in the API makes it very clear what it is.
Type: Usability Problem
Backwards Compatible: True
Due in version: 7.7.0
Sprint: Sprint 64