U4-10297 - Permission Bug for create document under root content tree

Created by Sam AY 16 Aug 2017, 01:44:42 Updated by Sam AY 18 Aug 2017, 03:16:46

Duplicates: U4-158

If you have not allow any Document Types "Allow as root" (Settings > Document Types > > Permissions > Allow as root

All of Document Types will show on content node ( Content > Content ) <--- bug ?

If I create a dummy document type and checked "Allow as root", under the content node will only show the dummy.

Comments

Sebastiaan Janssen 16 Aug 2017, 05:12:19

This was done for backwards compatibility, if you upgrade from older versions then no "allow at root" checkboxes would ever have been set and the behavior would suddenly change, forcing everybody to have to go into their site and set up "allow at root" everywhere. http://issues.umbraco.org/issue/U4-158#comment=67-4775


Sam AY 16 Aug 2017, 13:05:23

@sebastiaan I am new install version 7.6.3, not upgrade from old version. So should it happen ? If I have not checked any doc type allow at root, it should not show under content , right ?


Sebastiaan Janssen 16 Aug 2017, 13:27:06

It's just how it works Sam. For ALL installs: if you do not allow anything at root then everything is allowed at root.


Sam AY 18 Aug 2017, 03:16:46

Thanks for answer @sebastiaan


Priority: Normal

Type: Bug

State: Duplicate

Assignee:

Difficulty: Normal

Category: Security

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.6.3

Due in version:

Sprint:

Story Points:

Cycle: