U4-10428 - Can't drag Image in Image Cropper (in Umbraco 7.6.7)

Created by Kevin Jump 19 Sep 2017, 10:13:22 Updated by Bjarne Fyrstenborg 19 Sep 2017, 12:55:42

In Umbraco 7.6.7 you can't grab an Image and move it about while defining your Image crop.

Works as expected in Umbraco 7.6.6 - but in 7.6.7 you don't get the Move icon and you can't move the image.

Steps to reproduce:

  1. Install Umbraco (with starter kit for images)
  2. Add a Crop to the Image Cropper data type (e.g 200 x 200)
  3. select any image - click on the crop image
  4. try to move the image.

What should happen

  1. Mouse cursor should change to the Move Icon
  2. You should be able to move the image about - while holding down the mouse button

2 Attachments

Comments

Sebastiaan Janssen 19 Sep 2017, 12:11:27

Argh, that's super unfortunate! Good quick find Kevin, thanks so much for reporting immediately!

This is fixed in https://github.com/umbraco/Umbraco-CMS/commit/018a066f869b7b491e8d35b2d308c5dd8bf3cfb7

Bring on a new release... :-)


Bjarne Fyrstenborg 19 Sep 2017, 12:50:01

Didn't noticed that when submitting my PR: https://github.com/umbraco/Umbraco-CMS/pull/1633 Sorry for that :)

To fix both issue the z-index in ".umb-cropper .viewport:after" should just be a lower z-index than the z-index of ".umb-cropper .overlay, .umb-cropper-gravity .overlay"

Just tried to set the z-index to 490, which also fix the issue and keep the focal point behind the sticky header.


Sebastiaan Janssen 19 Sep 2017, 12:54:49

@Bjarne.Fyrstenborg Cool, we'll have to look into it later, first priority was to get a fix out ASAP.


Bjarne Fyrstenborg 19 Sep 2017, 12:55:42

@nul800sebastiaan I totally understand :)


Priority: Critical

Type: Bug

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.7.0, 7.6.7

Due in version: 7.7.1, 7.6.8

Sprint:

Story Points:

Cycle: