U4-10586 - Log Filled With "Could not find persisted pre-value for field"

Created by Nicholas Westby 24 Oct 2017, 20:08:55 Updated by Ismail Mayat 01 Aug 2018, 14:46:40

Tags: PR Consider for sprint

Here's an extract from my Umbraco log file:

2017-10-24 13:01:53,263 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:53,264 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:53,277 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field default 2017-10-24 13:01:53,290 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:53,293 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:53,294 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values 2017-10-24 13:01:53,295 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:53,306 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:53,309 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field onlyImages 2017-10-24 13:01:53,309 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field disableFolderSelect 2017-10-24 13:01:53,309 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:53,310 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field crops 2017-10-24 13:01:53,313 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field min 2017-10-24 13:01:53,313 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field step 2017-10-24 13:01:53,313 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:53,331 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field editor 2017-10-24 13:01:53,331 [P21340/D5/T56] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field hideLabel 2017-10-24 13:01:55,975 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:55,977 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:55,999 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field default 2017-10-24 13:01:56,020 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:56,025 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:56,027 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values 2017-10-24 13:01:56,028 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:56,046 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:56,051 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field onlyImages 2017-10-24 13:01:56,051 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field disableFolderSelect 2017-10-24 13:01:56,052 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:56,053 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field crops 2017-10-24 13:01:56,058 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field min 2017-10-24 13:01:56,058 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field step 2017-10-24 13:01:56,058 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:56,088 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field editor 2017-10-24 13:01:56,088 [P21340/D5/T20] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field hideLabel 2017-10-24 13:01:56,163 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:56,164 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:56,179 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field default 2017-10-24 13:01:56,288 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:56,292 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:56,293 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values 2017-10-24 13:01:56,294 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:56,304 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:56,307 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field onlyImages 2017-10-24 13:01:56,307 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field disableFolderSelect 2017-10-24 13:01:56,308 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:56,309 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field crops 2017-10-24 13:01:56,311 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field min 2017-10-24 13:01:56,311 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field step 2017-10-24 13:01:56,312 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:56,329 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field editor 2017-10-24 13:01:56,329 [P21340/D5/T51] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field hideLabel 2017-10-24 13:01:56,362 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:56,363 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:01:56,376 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field default 2017-10-24 13:01:56,388 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:56,392 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:01:56,393 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values 2017-10-24 13:01:56,394 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:56,404 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:56,407 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field onlyImages 2017-10-24 13:01:56,407 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field disableFolderSelect 2017-10-24 13:01:56,408 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:01:56,409 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field crops 2017-10-24 13:01:56,411 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field min 2017-10-24 13:01:56,411 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field step 2017-10-24 13:01:56,412 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:01:56,430 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field editor 2017-10-24 13:01:56,431 [P21340/D5/T33] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field hideLabel 2017-10-24 13:02:05,517 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:02:05,518 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars 2017-10-24 13:02:05,533 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field default 2017-10-24 13:02:05,545 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:02:05,549 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName 2017-10-24 13:02:05,550 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values 2017-10-24 13:02:05,551 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:02:05,561 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:02:05,564 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field onlyImages 2017-10-24 13:02:05,564 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field disableFolderSelect 2017-10-24 13:02:05,565 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId 2017-10-24 13:02:05,566 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field crops 2017-10-24 13:02:05,568 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field min 2017-10-24 13:02:05,568 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field step 2017-10-24 13:02:05,569 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max 2017-10-24 13:02:05,586 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field editor 2017-10-24 13:02:05,586 [P21340/D5/T43] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field hideLabel

Not sure what's causing that, but those look like prevalues from a data type (not sure which one). Umbraco 7.7.2

I'm not aware of this causing any functional issues, but it doesn't seem normal that the log file should have a bunch of these entries.

Comments

Andreas Kaltenhuber 27 Oct 2017, 06:45:06

Experience the same behavior. i just upgraded from 7.5.13 to 7.7.4 and my logs are filled with these warnings.


Veronica Burd 27 Oct 2017, 16:36:39

I have the same issue going from 7.7.3 to 7.7.4


Rodney Greenfield 27 Nov 2017, 22:39:23

I had the same issue going from 7.6.3 to 7.7.6


Rodney Greenfield 27 Nov 2017, 22:59:04

Also seems related to http://issues.umbraco.org/issue/U4-6819


Mladen B. 28 Dec 2017, 14:00:38

Was this ever understood why and how it happens? For example, I only noticed this when upgrading some nuget packages, so I assume something went wrong in the upgrade process...

UPDATE: The issue was with some of the default values of properties in some of the Data Types. I went through the list of all Data Types (and watched the App_Data\Logs\err.log file for changes) to figure out which DataTypes had issues and simply re-saved those that had. After that, no warnings were recorded in the log file.


Kevin Giszewski 03 Jan 2018, 20:26:40

Getting this today with an upgrade from 7.2.8 -> 7.7.7. Resaving presently doesn't seem to help.


Kevin Giszewski 03 Jan 2018, 20:53:37

Based on the field names, it seems that the resolver is confused with JSON property names:

This is adding a ton of bloat to the log (same group of errors many dozens of times). Appears when simple navigating to a piece of content that triggers this in the backoffice.

 2018-01-03 15:49:30,629 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field onlyImages
 2018-01-03 15:49:30,629 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field disableFolderSelect
 2018-01-03 15:49:30,629 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId
 2018-01-03 15:49:30,630 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values
 2018-01-03 15:49:30,636 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxChars
 2018-01-03 15:49:30,641 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startNodeId
 2018-01-03 15:49:30,644 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max
 2018-01-03 15:49:30,647 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field crops
 2018-01-03 15:49:30,668 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName
 2018-01-03 15:49:30,691 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName
 2018-01-03 15:49:30,705 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field mediaImagesOnly
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field mediaPreview
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field multipleItems
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxItems
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startWithAddButton
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field enableDisabling
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field oneAtATime
 2018-01-03 15:49:30,706 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field usePickerIcons
 2018-01-03 15:49:30,713 [P4220/D86/T113] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName
 2018-01-03 15:49:30,756 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field multipleItems
 2018-01-03 15:49:30,756 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field maxItems
 2018-01-03 15:49:30,756 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field startWithAddButton
 2018-01-03 15:49:30,756 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field enableDisabling
 2018-01-03 15:49:30,756 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field oneAtATime
 2018-01-03 15:49:30,756 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field usePickerIcons
 2018-01-03 15:49:30,758 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName
 2018-01-03 15:49:30,760 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field tabName
 2018-01-03 15:49:30,769 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field default
 2018-01-03 15:49:30,773 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field useLabel
 2018-01-03 15:49:30,776 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field min
 2018-01-03 15:49:30,777 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field step
 2018-01-03 15:49:30,777 [P4220/D86/T109] WARN  Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field max


Kevin Giszewski 03 Jan 2018, 20:58:53

Saving every single data type again (x2) did the trick. Spam seems to have gone away. Thanks for the tip @mladen074


Stefan Verleger 23 Jan 2018, 13:02:41

For most data types it worked, but for the data types with the property editor alias "Umbraco.NoEdit" i still get a warning. 2018-01-23 07:15:12,325 [P14196/D2/T117] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values

And for the data types with the with the property editor alias "Umbraco.ColorPickerAlias" i only get a warning when the checkbox "Include Labels" is not checked.


Biagio Paruolo 23 Jan 2018, 13:15:27

Here is the issue with Archetype https://our.umbraco.org/forum/templates-partial-views-and-macros/90179-archetypeapiarchetypedatatypecontroller


Carlos Casalicchio 15 Mar 2018, 02:51:24

I am also having this issue on a live site, and this is driving me and the client insane! I cannot save the content node, and I've reviewed all data types, and am not using NoEdit (Labels) anywhere in that content node. So I have no idea how to resolve this. 2018-03-14 19:45:01,819 [P11128/D2/T30] WARN Umbraco.Web.Models.Mapping.PreValueDisplayResolver - Could not find persisted pre-value for field values

Have tried removing the DataType and re-creating it, but the issue remains. Have also copied the db locally, and went through all the config files, and the warning continues locally but does not prevent me from saving the node. It is only in the remote (live server) that it breaks.

What I decided doing, and apparently that has fixed it, was to build the plugins in release mode, and deployed them to the server. Now the issue is gone.


Ronald Barendse 22 Mar 2018, 09:48:31

It would be a big help if the PreValueDisplayResolver also included the data type name/alias.

I've created a PR for this: https://github.com/umbraco/Umbraco-CMS/pull/2533


Mads Krohn 07 Jun 2018, 11:59:54

just did an update from 7.5 to 7.10 and we are seeing this as well :(


Ismail Mayat 01 Aug 2018, 14:46:40

We got a site on 7.10.4 its used archetype quite a bit


Priority: Normal

Type: Bug

State: Open

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Pull request

Affected versions: 7.7.2, 7.7.7, 7.10.4

Due in version:

Sprint:

Story Points:

Cycle: