U4-11543 - Mandatory fields validation in Nested Content doesn't work if the property is nested in LeBlender editor

Created by Ljiljana Kekic 30 Jul 2018, 10:02:06 Updated by Ljiljana Kekic 20 Aug 2018, 07:41:07

Your report will have a greater chance of being addressed if you can give us clear steps to reproduce the issue, please answer the following questions in as much detail as possible: What did you do?

In LeBlender editor I added property of type Nested Content. In that Nested Content I set mandatory fields. If I left mandatory fields empty while populating content and try to save that editor I don't get the required field error message, and I can save that editor.

What did you expect to happen?

I expected to see required field message and not to be allowed to save that editor until I populate all mandatory fields.

What actually happened?

I saved editor with all empty fields no matter if the field is mandatory or not.


I already saw the similar issue here: https://github.com/umco/umbraco-nested-content/issues/16 , but since that was in 2015. I wanted to check will you fix this issue with Nested Content mandatory fields in some future versions of Umbraco?

Kind regards, Ljiljana Kekic, Vega IT Sourcing

Comments

Sebastiaan Janssen 01 Aug 2018, 07:54:54

Hi @ljkekic - unfortunately, the message is still the same as it was for the Nested Content package, this is not something that we will fix.


Ljiljana Kekic 20 Aug 2018, 07:41:07

Hi @sebastiaan , thanks for the response.


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: