U4-1415 - v6 Installing on MySQL gives error

Created by Sebastiaan Janssen 08 Jan 2013, 16:41:29 Updated by Sebastiaan Janssen 16 Jan 2013, 21:00:29

Relates to: U4-1419

Relates to: U4-1452

Table umb.umbracouser doesn't exist

Comments

Sebastiaan Janssen 08 Jan 2013, 17:55:23

It only creates the umbraconode table


Sebastiaan Janssen 08 Jan 2013, 18:07:50

It's because umbraco is greedy and wants to purge logfiles and look up the "current" umbracouser. Not sure why this is showing up in the interface while it doesn't do this for SQL Server / SQL CE?


Sebastiaan Janssen 08 Jan 2013, 18:11:25

Line 767 of PetaPoco.cs is throwing: var factory = pd.GetFactory(cmd.CommandText, _sharedConnection.ConnectionString, ForceDateTimesToUtc, 0, r.FieldCount, r) as Func<IDataReader, T>;

CoreBootManage.Initialize() seems to be the original point of origin.

Why does this work fine on SQL/CE and not MySQL?


Sebastiaan Janssen 08 Jan 2013, 18:52:55

I don't know why but MySQL insists that this needs to be the first table to create, so moved it up the list. Changeset: 81007e760e86


Sebastiaan Janssen 09 Jan 2013, 06:21:08

That didn't really fix it, later I got errors like: Table umb.5dc_17d doesn't exist I have no idea what that is all about..


Morten Christensen 16 Jan 2013, 16:38:08

Wasn't this fixed yesterday? Think there were two issues about mysql installation and only one of them got updated.


Sebastiaan Janssen 16 Jan 2013, 21:00:23

Yes, that's why I was asking if you'd updated the issue yet.. :P


Priority: Major

Type: Bug

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.0.0

Due in version: 6.0.0

Sprint:

Story Points:

Cycle: