U4-1550 - Publish notifications on a load balanced environment

Created by Andrew Rees 25 Jan 2013, 09:09:01 Updated by Shannon Deminick 06 Mar 2014, 08:45:52

We've discovered an issue with email notifications not working as expected on a load balanced environment. Our clients website is currently running on a system consisting of 2 load balanced web services using DFSR for file replication, although the issue can be easily replicated outside of a load balanced system.

The users of the site have set up notifications for the "Send to Publish" and "Publish" events, and experience weird issues with the publish notifications. When a document gets published, a user gets sent a notification email from both servers, and even weirder instead of the name of the user who published the page, the email always says "Published by admin user".

The site itself is on 4.7.0, but I've replicated the same behaviour on a local 4.11.3 installation without load balancing. Originally the publish email notifications work correctly, but as soon as I change to the weird behaviour described above starts occurring.

The full section distributedCall section of my local config is

2 127.0.0.1:8084

Comments

Shannon Deminick 13 Jan 2014, 04:40:43

The issue is due to when the notifications are sent which is done in the content class which is incorrect.


Priority: Normal

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 4.9.1, 4.11.3

Due in version: 7.1.0, 6.2.0

Sprint:

Story Points:

Cycle: