U4-1563 - 6.0 RC: Allow at Root - Usability?

Created by Warren Buckley (Personal) 28 Jan 2013, 14:04:40 Updated by Mads Krohn 28 Jan 2013, 14:39:12

Relates to: U4-158

Hiya Guys, Come across the new Allow at Root feature in V6RC and I am not 100% sure it is working how I imagined it would work.

This is not a bug but more a question in regards for using it:

For example I have two doctypes both with the Allow at Root checkbox unchecked, so I would assume that I would not be able to create either of these two doctypes at the root, unless I specifically request a document type to be allowed at the root.

Created a quick Screenr showing my use case http://www.screenr.com/9I07

Cheers, Warren :)

Comments

Sebastiaan Janssen 28 Jan 2013, 14:07:59

See the related issue. For backwards compatibility if you don't allow any of them at the root level, then all will be allowed.


Warren Buckley (Personal) 28 Jan 2013, 14:10:36

Ah cheers. I see the note about backwards compatabilty, makes sense mate :)


Mads Krohn 28 Jan 2013, 14:12:34

Would be nice to disallow everything though. Yet another config setting perhaps?


Morten Christensen 28 Jan 2013, 14:26:44

"Nice to have" vs. "Backwards compatibility" ... Backwards compatibility wins for now. But hopefully we can change it in a later version, so not having any allowed doctypes at the root is possible. You could also write an event to remove the "Create" option from the context menu at the root to archive this.


Mads Krohn 28 Jan 2013, 14:39:12

Yeah, there are lots of ways to work around it, but glad it's not a bug, thought that as well :)


Priority: Normal

Type: Usability Problem

State: Closed

Assignee:

Difficulty: Normal

Category: UI

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: