U4-1850 - MVC templates are being deployed twice through package

Created by Andreas Iseli 06 Mar 2013, 11:00:21 Updated by Andreas Iseli 21 Apr 2013, 10:59:37

I've created a package with several MVC based templates. The rending engine is set to Mvc on both system, the origin and the target. The MVC views that are being created are not explicit added to the package, but I've tested that as well, there is no difference.

The problem is that the MVC templates on the origin system have an alias that differs from the name. Example:

  • Name: Startseite
  • Alias: StartPage

When deploying the package, the template with the "StartPage" alias should created only a "StartPage.cshtml" view file. But currently when deploying the package, on the target system two template view files are being created in the views folder:

  • Startseite.cshtml
  • StartPage.cshtml

This fortunately does not have any functional impacts and the template definition itself is correct. but may confuse administrators trying to digging out the file structure for updates.

1 Attachments

Download TestPackage_1 (1).zip

Comments

Sebastiaan Janssen 21 Apr 2013, 10:35:03

I can't actually reproduce this on 6.0.3, have you tried it there? I have the attached package, but it seems to work fine. Maybe you can attach a sample package so we can verify?


Andreas Iseli 21 Apr 2013, 10:59:37

Hello together. I've just give it a try with my package on 6.0.3 and the error seems to be gone. Perhaps the other deployment fixes had an influence on that as well. So for now you may just close this ticket. Thanks!


Priority: Minor

Type: Bug

State: Can't Reproduce

Assignee: Morten Christensen

Difficulty: Normal

Category: Packages

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.0.0, 6.0.1, 6.0.2

Due in version:

Sprint:

Story Points:

Cycle: