U4-2144 - CmsContentXml table is not updated with correct XML when a property alias is changed

Created by Shannon Deminick 24 Apr 2013, 08:08:44 Updated by Shannon Deminick 26 Apr 2013, 08:18:30

Relates to: U4-1772

Relates to: U4-2149

Currently the CmsContentXml table is not updated with the correct XML when a property alias is changed. Currently it only gets updated when the alias of a document type is changed. In 6.1 this is working but in previous versions it is not. What needs to happen is:

  • If any content type alias is changed, we need to re-gen the xml for all content of that type
  • If any content type property alias is changed, we need to re-gen the xml fro all content of that type and any of it's inherited types
  • If any property is deleted we need to re-gen the xml for all content of that type and any of it's inherited types

Comments

Shannon Deminick 25 Apr 2013, 01:15:59

We also need to ensure that we run the removal of a property in the pages async engine since we need to re-gen xml when this happens.


Shannon Deminick 25 Apr 2013, 01:31:50

Fixed in 1b6627ab2862 but will leave open until merged into main branch and then ported upwards to 6.x


Priority: Major

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 4.8.0, 4.9.0, 4.10.0, 4.11.0, 6.0.0, 4.9.1, 4.11.1, 4.11.2, 4.11.3, 4.11.4, 6.0.1, 4.11.5, 6.0.2, 4.11.6, 6.0.3

Due in version: 6.0.6, 4.11.9

Sprint:

Story Points:

Cycle: