U4-2293 - Error creating in fields in backoffice: There is already an open DataReader associated with this Command which must be closed first.

Created by Kurt Emch 29 May 2013, 19:38:02 Updated by Sebastiaan Janssen 30 May 2013, 07:24:54

Duplicates: U4-2172

I'm getting this error any time I try to create a field in any of my Document Types. I've been working with the same site for about 4 weeks so this error is a bit of a surprise and hindering any progress.

Screenshot of the error: http://cl.ly/image/0J081G2U2W1w Thread: http://our.umbraco.org/forum/using/ui-questions/41372-Align-images-left-and-right-float-in-rich-text-editor

I suspect it happened when I renamed, deleted, and recreated some existing document types, but that's only an assumption.

Umbraco 6.05, blank install. Packages installed: uComponents.

Comments

Kurt Emch 29 May 2013, 19:55:15

Update on this. After about 15-20 minutes, things started working as normal. Like something got recycled or something.


Sebastiaan Janssen 30 May 2013, 07:14:52

Possible solution is to enable MARS: http://stackoverflow.com/questions/6062192/there-is-already-an-open-datareader-associated-with-this-command-which-must-be-c

Haven't read about the implications yet though.


Sebastiaan Janssen 30 May 2013, 07:24:54

I see this has already been fixed for the next release (due out today) :-)


Priority: Normal

Type: Bug

State: Duplicate

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.0.5

Due in version:

Sprint:

Story Points:

Cycle: