U4-2402 - Publication Status incorrect after IIS restart

Created by Chris Mahoney 19 Jun 2013, 20:37:32 Updated by Morten Christensen 26 Jun 2013, 09:52:25

There appears to be an issue with the Publication Status field not persisting across IIS restarts.

  1. Log into the Umbraco backend.
  2. Edit a page, save, but don't publish.
  3. Note that the Publication Status (on the properties tab) shows the correct last published date.
  4. Also note that the orange asterisk shows up in the Content panel to indicate that the page has changed.
  5. Restart IIS (I did this by typing iisreset).
  6. Log back into the backend and go back to the test page.
  7. The orange asterisk is now gone and Publication Status lists the edit date instead of the published date.

I've seen this happen with 6.0.5 and 6.0.6 but haven't tested any other versions.

Comments

Sebastiaan Janssen 21 Jun 2013, 14:51:17

@Morten wasn't this fixed in 6.0.6?


Morten Christensen 21 Jun 2013, 14:55:06

It was fixed as part of the tree optimization refactoring, but can't remember if we moved that to 6.1.0 or if was also part of 6.0.6 :-S


Sebastiaan Janssen 21 Jun 2013, 15:46:33

I think this is it,no? https://umbraco.codeplex.com/SourceControl/changeset/c4fe2011197b


Morten Christensen 21 Jun 2013, 16:02:40

No, its using the EntityService and its changes to the BaseContentTree and BaseMediaTree.


Sebastiaan Janssen 23 Jun 2013, 14:25:26

Gotcha, commit b19621c07bf3979e0a3ac1836e177e67d43aaedb it is. It looks like we should be able to make the icon-specific changes to 6.0.x as well, correct?


Morten Christensen 26 Jun 2013, 09:52:25

Fix can't be backported to 6.0.x so its recommended to update to 6.1.x to resolve the above mentioned issue


Priority: Normal

Type: Bug

State: Fixed

Assignee: Morten Christensen

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.0.6, 6.0.5

Due in version: 6.1.1

Sprint:

Story Points:

Cycle: