U4-2510 - tinyMCE Spellchecker Broken

Created by Andrew 15 Jul 2013, 11:52:31 Updated by Adrian Holland 31 Jul 2013, 01:12:09

Duplicates: U4-2060

The spellcheck function of tinyMCE is broken in the latest version and it seems (judging by forum posts) it is broken in several other versions.

I've found a fair amount of forum posts from people wanting this function working.

http://our.umbraco.org/forum/getting-started/installing-umbraco/41834-TinyMce-Editor-Auto-Spell-Check

http://our.umbraco.org/forum/developers/api-questions/43145-tinyMCE-Spellcheck-not-working-in-612

http://our.umbraco.org/forum/ourumb-dev-forum/bugs/43146-TinyMCE-spellcheck-error-You-must-write-ContentLength-bytes-to-the-request-stream

http://our.umbraco.org/projects/backoffice-extensions/newsletter-studio/comments/37596-Spellcheck-doesn

Search and you will find plenty more.

Comments

Adrian Holland 31 Jul 2013, 01:12:09

The Google spellchecker service this relies on (https://www.google.com/tbproxy/spell) may have been turned off for good - http://0-productforums.google.com.library.ccbcmd.edu/forum/#!topic/chat/CPb0PYllbE8 An alternative is the HunSpellChecker plugin http://our.umbraco.org/projects/backoffice-extensions/hunspellchecker

Its not been tested on V6 but I don't see any reason why it wouldn't work...


Priority: Normal

Type: Bug

State: Duplicate

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.1.2

Due in version:

Sprint:

Story Points:

Cycle: