U4-2881 - umbraco dll/assembly SemVersioning #SemVer

Created by andrew shearer 17 Sep 2013, 23:33:36 Updated by Sebastiaan Janssen 30 Sep 2013, 08:10:55

Would it be possible for the 6.2 release to follow semver convention for dll/assemblies in the same way as the nuget package version they reside within? thanks

Comments

Sebastiaan Janssen 18 Sep 2013, 07:09:04

Nope, it's a huge breaking change, NONE of the packages built against v4 or 6 will work any more. We've discussed it a few times internally and even with all kinds of workarounds it requires just so much work and testing that it's really not worth the time put in (not even for major versions as most packages will actually still work with new major versions if we don't do this). Closing this as it will likely never happen.


andrew shearer 29 Sep 2013, 07:08:41

not even under umb7?


Sebastiaan Janssen 30 Sep 2013, 08:10:55

Nope. As said, we can't do it without breaking 100% of the packages out there.


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: