U4-2906 - Need to convert ALL calls to the legacy Document business logic layer to the new one

Created by Shannon Deminick 21 Sep 2013, 02:52:16 Updated by Shannon Deminick 09 Oct 2013, 04:48:30

Subtask of: U4-2888

We need to do this because otherwise people will get YSODs when using new property editors that do not have an associated legacy GUID. Of course people can fix this by assigning a legacy GUID to the LegacyPropertyEditorIdToAliasConverter but in the core we cannot rely on that and must use the new APIs

Comments

Shannon Deminick 27 Sep 2013, 02:19:56

I have fixed the ysods by creating a runtime legacy IDataType instance but we should still look at converting to the new services, waiting on feedback from HQ.


Shannon Deminick 09 Oct 2013, 04:48:24

Improvements have been made with backwards compatibility with the legacy APIs so they should work where they currently exist in the codebase.


Priority: Normal

Type: Task

State: Closed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version: 7.0.0

Sprint:

Story Points:

Cycle: