U4-2958 - Member can edit & Show on profile do not persist on Member Type editor

Created by Shannon Deminick 27 Sep 2013, 02:37:50 Updated by patrick Livbom 26 Mar 2014, 10:33:20

Subtask of: U4-1659

I'm not sure if this is just a v7 thing but since we haven't made many changes to members in v7 I'd assume this issue exists in v6 as well.

Comments

Sebastiaan Janssen 27 Sep 2013, 08:00:46

Works in v6.


Sebastiaan Janssen 30 Sep 2013, 12:22:06

In v6 I also see this but ONLY after just adding a new property and then immediately checking on the show on profile/member can edit checkboxes. It works fine if I first click on the member type again and then save the checkboxes.


Sebastiaan Janssen 30 Sep 2013, 12:23:59

Maybe not, unchecking them again doesn't work, before taking any action you always need to click on the member type again and after that saving will work, once. Something funky going on there for sure.


Andy Butland 02 Oct 2013, 19:24:03

Have submitted a tiny pull request for this issue: https://github.com/umbraco/Umbraco-CMS/pull/147


Sebastiaan Janssen 05 Oct 2013, 17:05:11

Thanks Andy, works like a charm!


Sebastiaan Janssen 05 Oct 2013, 17:10:47

Fixed in rev fe18722e1fda5f740e66b69f819e585de9d5c8af


patrick Livbom 26 Mar 2014, 10:33:20

I am experiencing this in 7.1 now, the workaround with first hitting the membertype folder and then member -> checking the boxes directly and save once is working


Priority: Normal

Type: Task

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Pull request

Affected versions: 6.0.0, 6.1.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.1.1, 6.0.6, 6.0.5, 6.0.7, 6.1.2, 6.1.3, 6.1.4, 6.1.5

Due in version: 6.2.0

Sprint:

Story Points:

Cycle: