U4-3151 - 'Reload Nodes' menu option results in never ending update bar

Created by Matt Bliss 15 Oct 2013, 11:24:26 Updated by Shannon Deminick 16 Oct 2013, 22:29:58

Clicking on 'Reload Nodes' under Developer > Packages > Install Starter Kit or Packages > Install Local Package results in a never ending update bars in the menu as no results will ever returned for these options.

Comments

Sebastiaan Janssen 15 Oct 2013, 11:26:10

What javasript errors do you get?


Matt Bliss 15 Oct 2013, 11:33:41

Hi Seb, hope these help:

GET http://localhost:13515/umbraco/UmbracoTrees/LegacyTree/GetNodes? 500 (Internal Server Error) angular.min.js:106 ReferenceError: arrow is not defined at http://localhost:13515/umbraco/js/umbraco.services.js:3826:75 at o (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:80:3) at http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:81:80 at Object.e.$eval (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:92:272) at Object.e.$digest (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:90:142) at Object.e.$apply (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:92:431) at j (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:101:80) at r (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:104:449) at XMLHttpRequest.v.onreadystatechange (http://localhost:13515/umbraco/lib/angular/1.1.5/angular.min.js:106:90) angular.min.js:63


Sebastiaan Janssen 15 Oct 2013, 11:50:16

Thanks! Did you have v7 installed on the same URL before (alpha, nightly) by any chance? Try clearing browser cache or a different browser. I'm assuming you're using the beta, correct?


Sebastiaan Janssen 15 Oct 2013, 11:52:54

Never miind, Install Local Package and Install Starter Kit should not have the Reload option, there are no children.


Matt Bliss 15 Oct 2013, 12:37:49

FYI: I did have a pre alpha nightly installed and I am now using the Beta. Agree though that the option shouldn't be present anyway. Thanks, Matt


Shannon Deminick 16 Oct 2013, 22:29:50

This was fixed in http://issues.umbraco.org/issue/U4-2928


Priority: Minor

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.0

Due in version: 7.0.0

Sprint:

Story Points:

Cycle: