U4-3264 - Content picker still shows 'Add' button even though you can't add anymore

Created by Shannon Deminick 29 Oct 2013, 04:08:07 Updated by Per Ploug 30 Oct 2013, 09:55:48

Relates to: U4-3263

By default the content picker is not a multi-picker (i havent tested with that option turned on either). When you select an item, the 'Add' button still appears but you can only pick one and it of course doesn't actually be able to select another.

Comments

Shannon Deminick 29 Oct 2013, 04:10:36

Also it would be worth looking into the various picker controllers we have and if they are actually used (and work). The one that I think is not used is Umbraco.Dialogs.ContentPickerController since the content picker actually launches the Umbraco.Dialogs.TreePickerController dialog. But then I'm not really sure that the Umbraco.Dialogs.TreePickerController will actually work for members or media since those pickers actually require some custom logic to deal with those types specifically.


Per Ploug 29 Oct 2013, 21:04:26

We can make the picker toggle between "add" and "choose" depending on if its a multipicker or not


Shannon Deminick 29 Oct 2013, 21:05:55

cool, sounds good


Per Ploug 30 Oct 2013, 09:55:48

If nothing is selected, or if its a multipicker the add link will show


Priority: Normal

Type: Bug

State: Fixed

Assignee: Per Ploug

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version: 7.0.0

Sprint:

Story Points:

Cycle: