U4-3325 - umbraco7 UX: navigating through menu, panel and content areas

Created by andrew shearer 05 Nov 2013, 08:06:54 Updated by andrew shearer 21 Nov 2013, 22:00:38

Is it possible for the panel and content containers to initialize when an option is selected from the primary nav menu?

Here’s a screencast of what I’m referring to: http://www.screenr.com/OBvH

In my example I select Content and then ‘Document Types’. Rather than performing any further action in this section, I click on the ‘Admin’ icon and ‘Edit Profile’ which displays the corresponding form. Finally, I go back to the Document Types section under Settings.

Is the expectation that each time I select an option from the primary Menu (i.e. Admin, Content, Settings etc) that anything loaded prior into the Panel or Content areas should disappear? Otherwise there's overlay issues and/or the UI doesn't quite reflect the last action correctly.

+1 for the panel being fixed now by the way :-)

(Based on nightly build 148 nuget package)

Comments

andrew shearer 05 Nov 2013, 08:17:28

To elaborate further, if I click on ‘Content’ from the primary menu and then ‘Content’ from the Panel, then the main area is loaded with the dashboard i.e. Get Started, Last Edits, Change Password. But shouldn't that happen when clicking the primary menu? 1 less click that way, and would also resolve the problem reported in my OP. thanks


David Conlisk 05 Nov 2013, 15:40:51

Still an issue in v7 RC, though unsure if this is by design?


andrew shearer 05 Nov 2013, 23:25:55

H David, Yep it’s still the same under the RC. Yes, as I now understand, it is by design as a result of the usability phase the project went through.


Per Ploug 13 Nov 2013, 13:30:50

We're currently cleaning up how the app internally manages state, this fixes this issue as well, as its really just a matter of a dialog being out of sync with tree and section


andrew shearer 16 Nov 2013, 02:38:23

great :) Is this in the nightly build nuget feed now? I'll grab it and have a test.


andrew shearer 21 Nov 2013, 22:00:38

this is still an issue in 7RTM


Priority: Normal

Type: Bug

State: Reopened

Assignee: Per Ploug

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.0

Due in version: 7.0.0

Sprint:

Story Points:

Cycle: