U4-3337 - Not able to create new member

Created by Tim Geyssens 05 Nov 2013, 08:27:34 Updated by Per Ploug 19 Nov 2013, 11:55:46

Have member types but member create dialog doesn't show the inputs...

Comments

Tim Geyssens 05 Nov 2013, 09:13:55

In my case http://localhost:22471/umbraco/UmbracoApi/MemberType/GetAllTypes returns a 500

{"Message":"An error has occurred.","ExceptionMessage":"An item with the same key has already been added.","ExceptionType":"System.ArgumentException","StackTrace":" at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)\r\n at System.Collections.Generic.Dictionary2.Insert(TKey key, TValue value, Boolean add)\r\n at System.Collections.Generic.Dictionary2.Add(TKey key, TValue value)\r\n at Umbraco.Core.Persistence.Factories.MemberTypeReadOnlyFactory.GetPropertyTypeGroupCollection(MemberTypeReadOnlyDto dto, MemberType memberType) in f:\TeamCity\buildAgent\work\e1a0ddf7a1349eaf\src\Umbraco.Core\Persistence\Factories\MemberTypeReadOnlyFactory.cs:line 87\r\n at Umbraco.Core.Persistence.Factories.MemberTypeReadOnlyFactory.BuildEntity(MemberTypeReadOnlyDto dto) in f:\TeamCity\buildAgent\work\e1a0ddf7a1349eaf\src\Umbraco.Core\Persistence\Factories\MemberTypeReadOnlyFactory.cs:line 34\r\n at System.Linq.Enumerable.WhereSelectListIterator2.MoveNext()\r\n at Umbraco.Core.Persistence.Repositories.RepositoryBase2.GetAll(TId[] ids) in f:\TeamCity\buildAgent\work\e1a0ddf7a1349eaf\src\Umbraco.Core\Persistence\Repositories\RepositoryBase.cs:line 159\r\n at Umbraco.Core.Services.MemberTypeService.GetAllMemberTypes(Int32[] ids) in f:\TeamCity\buildAgent\work\e1a0ddf7a1349eaf\src\Umbraco.Core\Services\MemberTypeService.cs:line 36\r\n at Umbraco.Web.Editors.MemberTypeController.GetAllTypes()\r\n at lambda_method(Closure , Object , Object[] )\r\n at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.<>c__DisplayClass13.b__c(Object instance, Object[] methodParameters)\r\n at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.ActionExecutor.Execute(Object instance, Object[] arguments)\r\n at System.Web.Http.Controllers.ReflectedHttpActionDescriptor.<>c__DisplayClass5.b__4()\r\n at System.Threading.Tasks.TaskHelpers.RunSynchronously[TResult](Func`1 func, CancellationToken cancellationToken)"}


Per Ploug 05 Nov 2013, 09:15:32

check your membertype alias's anyone of them the same?


Tim Geyssens 05 Nov 2013, 09:17:33

Nope got Member and a so both are different...


Tim Geyssens 05 Nov 2013, 09:18:07

Got the same with a single member type...


Tim Geyssens 05 Nov 2013, 09:18:38

If I delete the one that is called Member it works ...


Per Ploug 05 Nov 2013, 09:24:54

on sql ce? - then I'll try to replicate in the next round of tests


Per Ploug 13 Nov 2013, 14:48:56

still havnt been able to replicate, is still an issue Tim?


Shannon Deminick 14 Nov 2013, 08:59:50

i can't replicate at all


Tim Geyssens 14 Nov 2013, 09:27:43

Nope only happened once ... so let's close it


Priority: Normal

Type: Bug

State: Closed

Assignee: Per Ploug

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.0

Due in version: 7.0.0

Sprint:

Story Points:

Cycle: