U4-3470 - Rich Text Editor DataType - Toolbar doesn't show additional icons / options when they are ticked in Toolbar Configuration screen

Created by Marc Goodson 10 Nov 2013, 21:37:12 Updated by Sebastiaan Janssen 19 Mar 2014, 16:12:39

Is duplicated by: U4-3543

Is duplicated by: U4-3557

Is duplicated by: U4-4458

Is duplicated by: U4-4473

In Release candidate of 7.0.0

#Add a Rich Text Editor based property to your doc type #In the datatype section customize the toolbar, ie tick every single box #flip to the content view, create a document based on the doc type that contains the rich text editor #some but not all configured icons are added.

Errors in console window are failed to load resource at /umbraco/%7B%7Bcmd.icon%7D%7D

5 Attachments

Comments

Shannon Deminick 15 Nov 2013, 01:32:50

I can get most of them to show up but what definitely is not working is the selected styles.


Ahmed Abdul Moniem 17 Nov 2013, 19:39:55

Having the same issue here ..

Can anyone plz tell us what is /umbraco/%7B%7Bcmd.icon%7D%7D?

I can't add macros using the rich editor and this is so vital to my application now?!


Mark van Schaik 21 Nov 2013, 20:49:47

Hey guys this is not fixed (at least the linked issue - U4-3557 isn't). Quite a major actually, no image picker after you add the style dropdown - quite an issue for clients/content editors.


Marc Goodson 21 Nov 2013, 21:22:04

When I upgraded from the RC I still had the problem, but a clean install of 7 worked for me, I have custom styles in the dropdown too, (using chrome on windows)


Janae Cram 21 Nov 2013, 21:39:59

The selected styles work for me, but I have to put all my styles beneath the /* EDITOR PROPERTIES - PLEASE DON'T DELETE THIS LINE TO AVOID DUPLICATE PROPERTIES */ whereas I used to be able to put them above it before.


Mark van Schaik 21 Nov 2013, 22:12:47

@marc ok cool, we will try this - we did just upgrade from RC.


Sebastiaan Janssen 19 Mar 2014, 10:50:07

Fixed the last remaining error for this issue in rev 307ea6bd74ac12ea2e55149cf272bdebbe1d9d84 (js error: /umbraco/%7B%7Bcmd.icon%7D%7D?)


Priority: Major

Type: Bug

State: Fixed

Assignee: Per Ploug

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.0

Due in version: 7.1.0

Sprint:

Story Points:

Cycle: