U4-3472 - New document type properties are lost after restarting iis express (v7 + WebMatrix)

Created by Justin 11 Nov 2013, 01:26:28 Updated by Justin 11 Nov 2013, 15:25:54

I was following the tutorial to add a new custom mark down editor. http://umbraco.github.io/Belle/#/tutorials/Adding-Configuration-To-Property-Editor

I have added a new property to the "TextPage" document type for my new "MarkDown" property editor. Every time I recycle the app pool (via the restart button in WebMatrix), the property "MarkDown" is no longer listed on my document type.

**** PLEASE CLOSE THIS BUG **** I was not able to reproduce. I think I had something in my manifest that was causing the property type not to load. Sorry for the bogus bug.

Comments

Justin 11 Nov 2013, 01:29:57

For reference, I am using the standard installation of 7.0RC using SQL CE and the TXT starter kit.


Shannon Deminick 11 Nov 2013, 06:59:06

Hi @Justin, so just confirming this is not an issue?


Per Ploug 11 Nov 2013, 09:46:41

This is a bug in Webmatrix and SQL CE - due to the way Webmatrix doesnt flush the database instantly, so in some cases you loose data when working in SQL CE. its only the scenario with Webmatrix and SQL CE that this happens in, we have not been able to fix this, but have been in touch with microsoft about it.


Justin 11 Nov 2013, 15:25:54

Per, that make a lot of sense. I can't reliably reproduce the behavior. Thanks for the quick response.


Priority: Major

Type: Bug

State: Closed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.0

Due in version: 7.0.0

Sprint:

Story Points:

Cycle: