U4-3636 - Umbraco 6 & Version 7 with Mysql

Created by Peter Adesokan 21 Nov 2013, 13:31:02 Updated by Carlos Casalicchio 13 May 2016, 13:01:09

Hello there.

I am fairly new to umbraco and i keep getting this error when i try to install umbraco 6.1xx and the new umbraco 7.00

Can anybody help .

The database configuration failed with the following message: Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause Please check log file for additional information (can be found in '/App_Data/Logs/UmbracoTraceLog.txt')

Comments

Bharat Vervesys 25 Jul 2014, 11:05:31

I am also facing the same issue and also created issue for this : U4-5277 Installing Umbraco 7.0.0 with MySql 5.5


Bjarne Fyrstenborg 27 Jul 2014, 15:54:08

Do you still have the issue with the latest version of Umbraco? v. 6.2.1 and v. 7.1.4 There were some issues with Umbraco 7 and when using MySql in the first versions of Umbraco 7.. and I would recommend to install or upgrade to Umbraco 7.1.4 as it is far more stable than the first releases of Umbraco 7.. furthermore for Umbraco 6, v. 6.2.0 had a lot of bug fixes.. so maybe this issues had been fixed in v. 6.2.1?


Bharat Vervesys 28 Jul 2014, 11:14:55

@Bjarne.Fyrstenborg thanks for reply.

Actually Umbraco 7.0.0 + MySql was client's specific requirement.

We also found that Umbraco 7.0.0 + MySql has some issue, because when we tried with Umbraco 7.1.3 + MySql it works fine but when we tried with Umbraco 7.0.0 + MySql it has same error and at same time when we tried Umbraco 7.0.0 + MS-SQL it works fine so we conclude that Umbraco 7.0.0 + MySql has some problem and we convinced client to use Umbraco 7.1.3


Bjarne Fyrstenborg 28 Jul 2014, 13:20:58

Yes, there were some issues with MySql in previous version of Umbraco 7, among others there were in version before 7.1.0 an issue that you got an error message when accessing package tree, so you were not able to install packages from backoffice UI with MySql in those versions of Umbraco but is now fixed.

if you start a new project I would recommend to use Umbraco 7.1.4 or soon 7.1.5 .. and later 7.2.0 if you want the latest features and some bug fixes.


AnjaB 08 Oct 2015, 21:13:00

I had this issue today with Umbraco 7.3.0 and Mysql. Now I installed UmbracoCms 7.2.8 and the installation went through.


Carlos Casalicchio 11 May 2016, 14:41:21

I have just downloaded the latest version (7.4.3) and got this error (new install):

2016-05-11 07:30:52,242 [P52668/D6/T19] ERROR Umbraco.Web.Install.Controllers.InstallApiController - Installation step DatabaseInstall failed. System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Umbraco.Web.Install.InstallException: The database failed to install. ERROR: The database configuration failed with the following message: Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause Please check log file for additional information (can be found in '/App_Data/Logs/UmbracoTraceLog.txt') at Umbraco.Web.Install.InstallSteps.DatabaseInstallStep.Execute(Object model) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at Umbraco.Web.Install.Controllers.InstallApiController.ExecuteStep(InstallSetupStep step, JToken instruction) 2016-05-11 07:30:52,242 [P52668/D6/T19] INFO Umbraco.Web.Install.Controllers.InstallApiController - Step completed (took 149ms) 2016-05-11 07:30:52,242 [P52668/D6/T19] ERROR Umbraco.Web.Install.Controllers.InstallApiController - An error occurred during installation step DatabaseInstall System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Umbraco.Web.Install.InstallException: The database failed to install. ERROR: The database configuration failed with the following message: Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause Please check log file for additional information (can be found in '/App_Data/Logs/UmbracoTraceLog.txt') at Umbraco.Web.Install.InstallSteps.DatabaseInstallStep.Execute(Object model) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at Umbraco.Web.Install.Controllers.InstallApiController.ExecuteStep(InstallSetupStep step, JToken instruction) at Umbraco.Web.Install.Controllers.InstallApiController.PostPerformInstall(InstallInstructions installModel) 2016-05-11 07:36:25,607 [P52668/D6/T10] ERROR UmbracoExamine.DataServices.UmbracoLogService - Provider=InternalMemberIndexer, NodeId=-1 System.Exception: Cannot index queue items, the index doesn't exist!,, IndexSet: InternalMemberIndexSet 2016-05-11 07:36:25,607 [P52668/D6/T10] ERROR UmbracoExamine.DataServices.UmbracoLogService - Provider=InternalIndexer, NodeId=-1 System.Exception: Cannot index queue items, the index doesn't exist!,, IndexSet: InternalIndexSet 2016-05-11 07:36:25,607 [P52668/D6/T10] ERROR UmbracoExamine.DataServices.UmbracoLogService - Provider=ExternalIndexer, NodeId=-1 System.Exception: Cannot index queue items, the index doesn't exist!,, IndexSet: ExternalIndexSet

Hosting Details:

Godaddy Clean install Windows Shared Hosting, added MySql 5.5


Marco Yoneda 13 May 2016, 12:47:38

I got the same error as Carlos Casalicchio... Any suggestions?


Carlos Casalicchio 13 May 2016, 13:01:09

@MarcoYoneda

I have installed it on my local computer using WebMatrix and Xampp (for mySQL) and it runs fine. I'm thinking it has something to do with Godaddy's setup (as it usually does) in my case.

Often I install my clint's websites on a free web hosting, before moving the site to it's final destination. But I'm guessing this time I'll just stick with the local machine, cause besides Godaddy I don't know of any other free (or cheap) hosting services for asp.net


Priority: Normal

Type: Bug

State: Submitted

Assignee:

Difficulty: Normal

Category: Installation

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: