U4-3679 - Using two data types with the Media Picker data editor multiple/not multiple

Created by Olov Nilzén 22 Nov 2013, 15:40:06 Updated by Sebastiaan Janssen 26 Nov 2013, 14:37:51

Is duplicated by: U4-3715

Relates to: U4-3645

We have to media picker data types, "Media Picker" and "Media Picker Multiple". On "Media Picker" we havn't checked "Pick multiple items" and it's checked on "Media Picker Multiple".

When using both data types on the same document type we can't select multiple items in the property which is the "Media Picker Multiple".

Comments

Shannon Deminick 25 Nov 2013, 06:40:21

Have you created both of these data type's yourself?

The Media Picker data type that is shipped with Umbraco renders a property editor called: "Legacy Media Picker" which does not allow choosing multiple.


Shannon Deminick 25 Nov 2013, 06:56:46

I can replicate this now - just the opposite way. Looking in to it now.


Olov Nilzén 25 Nov 2013, 06:58:38

Yes, I changed from "Legacy Media Picker" to "Media Picker" on the built in "Media Picker" data type. And the reason for that was that I was able to pick multiple images (This in an site upgraded from Umbraco 6).


Shannon Deminick 25 Nov 2013, 08:42:05

Fixed in 683862932ba3cbb47136a70e105243cfadd1b834

Thanks for finding this - the underlying problem has other consequences when having more than one property defined by different data types that are using the same underlying property editor where you data types have different pre-values. The bug unfortunately means that the previous pre-values may get overwritten in memory from the last rendered property's editor at an application level.


Priority: Show-stopper

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.0

Due in version: 7.0.1

Sprint:

Story Points:

Cycle: