U4-368 - Multiple upload properties on the Image media type makes the "create new" feature of the Media Picker fail

Created by Sebastiaan Janssen 19 Aug 2012, 14:51:32 Updated by Sebastiaan Janssen 11 Sep 2013, 18:25:32

Multiple upload properties on the Image media type causes the "create new" feature of the Media Picker and Insert Images feature in the RTE fail.

Steps to reproduce:

  • Add an additional upload property to the Image media type.
  • Edit a page with a Media Picker property.
  • Select Create new, and upload a new image.

Workaround

  • Sort the upload properties in the Image media type so that the original upload property (umbracoFile) is positioned last.

''Originally created on CodePlex by [milandt|http://www.codeplex.com/site/users/view/milandt]'' on 2/15/2011 4:40:00 PM [Codeplex ID: 30038 - Codeplex Votes: 2]

Imported comments

''Comment by [jbreuer|http://www.codeplex.com/site/users/view/jbreuer] on 2/21/2011 9:35:38 AM:'' I know how this works. If you look at the source code you see it looks for all the upload fields of a media type, but loops through them and selects the last one found so that's why your workaround works :). I developed a media picker myself which looks for the first upload field and uses that one. You can download it here: http://our.umbraco.org/projects/backoffice-extensions/digibiz-advanced-media-picker

Jeroen

''Comment by [sebastiaan|http://www.codeplex.com/site/users/view/sebastiaan] on 8/9/2012 11:50:28 AM:'' We haven't been very good at maintaining the issue tracker and with 1250+ open bugs we can't be sure which ones have been fixed and when (if they are even fixed).

To keep the issue list maintainable, on Monday the 13th of August, we will be moving the issue tracker over to YouTrack (http://issues.umbraco.org) where we'll only import the issues that have been updated in the past 12 months (which means: they had comments or votes in the past year).

If you think this issue (that has had no activity in the past year) is still worth looking at then please comment and we'll look into re-opening it.

** Closed by sebastiaan 08/09/2012 2:50AM

''Comment by [jbreuer|http://www.codeplex.com/site/users/view/jbreuer] on 8/13/2012 10:59:04 AM:'' This probably isn't fixed yet.

''Comment by [sebastiaan|http://www.codeplex.com/site/users/view/sebastiaan] on 8/15/2012 3:11:47 AM:''


Comments

Sebastiaan Janssen 11 Sep 2013, 18:25:26

Can't reproduce this in 6.1.5.


Priority: Normal

Type: Bug

State: Can't Reproduce

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: