U4-4031 - 7.0.1 - TinyMCE configuration not applied

Created by Panayiotis Tritakis 12 Jan 2014, 22:06:28 Updated by Shannon Deminick 13 Feb 2014, 04:03:49

Relates to: U4-3966

The tinyMceConfig.config file contains (towards the end) a '''' section with the stated purpose of allowing the specification of additional configuration options to be applied to the the editor. In a clean 7.0.1 installation the section looks like this: raw GoogleSpellChecker.ashx However these options never seem to be applied to the actual TinyMCE instance used in the back office.

During the initialization of the TinyMCE instance (''umbraco.controller.js'' around line 4750) the custom configuration settings are retrieved from the config file and are available in '‘tinyMceConfig.customConfig'’. However they are not passed to the initialization routine of the editor (the ''tinymce.init'' call is approximately at line 4820) and therefore TinyMCE uses the default values for the respective settings.

Comments

Panayiotis Tritakis 12 Jan 2014, 22:09:43

Since none of the custom configuration options are applied, neither is directionality.


Karl Tynan 17 Jan 2014, 16:29:46

Would definitely like to see this rectified.


Steve Temple 31 Jan 2014, 23:24:43

Have submitted a pull request for this issue https://github.com/umbraco/Umbraco-CMS/pull/293


Priority: Normal

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Pull request

Affected versions: 7.0.1

Due in version: 7.1.0

Sprint:

Story Points:

Cycle: