U4-4169 - Umbraco 6.1.6 NuGet package - Developer tab does not load Examine management.

Created by Can Koluman 03 Feb 2014, 13:16:24 Updated by a david 13 Aug 2014, 19:01:44

Install Umbraco 6.1.6 via NuGet, and login to the backend. Navigate to the 'Developer' area. An inline pop-up comes up, and the 'Examine Management' tab does not load.

See screenshots below.

Cause: Wrong version of these: (Microsoft.AspNet.WebApi.WebHost.4.0.20505.0) (Microsoft.AspNet.WebApi.Core.4.0.20505.0) (Microsoft.AspNet.WebApi.Client.4.0.20505.0) (Newtonsoft.Json.4.5.1.14720) Microsoft.AspNet.WebApi.4.0.20505.0

Resolution: Update UmbracoCms.Core.6.1.6 NuGet package to use minimum versions (Microsoft.AspNet.WebApi.WebHost.4.0.20710.0) (Microsoft.AspNet.WebApi.Core.4.0.20710.0) (Microsoft.AspNet.WebApi.Client.4.0.20710.0) (Newtonsoft.Json.4.5.11.15520) Microsoft.AspNet.WebApi.4.0.20710.0

Basically when you update Microsoft.AspNet.WebApi.4.0.20710.0, everything else appears to adjust in version.

3 Attachments

Download UmbracoCms.Core.6.1.6.nuspec

Comments

Sebastiaan Janssen 18 Mar 2014, 18:24:44

I've updated the required reference, this should not be a problem for 6.2.0 any more. Revision 7c5942b05f62f96e92e8e2045e2349a89745d109

If at all possible it would be fantastic if you could test this out:

Alright, I've been updating the NuGet packages and hopefully they should start working now. If anybody could be so kind and test the following:

  1. Download https://dl.dropboxusercontent.com/u/3006713/UmbracoNuGet/UmbracoCms.6.2.0-QA.nupkg and https://dl.dropboxusercontent.com/u/3006713/UmbracoNuGet/UmbracoCms.Core.6.2.0-QA.nupkg
  2. Put them in a known location, like C:\Temp
  3. Create a new project in Visual Studio: File > New Project > Blank Project (don't choose MVC or Webforms or anything, just blank)
  4. Go to your package manager console and install the test package using this command (replace C:\Temp with your own path):
    Install-Package UmbracoCms -Version 6.2.0-QA -Pre -Source C:\temp
  5. Hit F5, install Umbraco
  6. Let me know if that works!


Can Koluman 11 Jun 2014, 08:39:15

Hi Sebastiaan,

Sorry for the extremely late reply. OK, I tested this and it is doing fine. Thanks.


a david 13 Aug 2014, 19:01:44

Hi, I don't want to upgrade my version (am using 6.1.1), is there anything else I can do to remedy this? It is strange because it doesn't happen in our UAT environment, however it does happen in our PROD environment, which is a COPY of the DB and files in UAT.


Priority: Normal

Type: Bug

State: Fixed

Assignee:

Difficulty: Easy

Category: Installation

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.1.6

Due in version: 6.2.0

Sprint:

Story Points:

Cycle: