U4-4239 - 7.0.3 Multinode tree picker not saving sort order

Created by Peter Gregory 17 Feb 2014, 04:29:08 Updated by Sebastiaan Janssen 24 Feb 2014, 11:51:31

When trying to sort picked nodes in the MNTP the new order is not saved. I have observed in 2 separate Umbraco installs. No errors are shown and nothing is in the log. I assume that possibly the property editor's value is not considered dirty and not making it to the DB? This issue duplicates loads of closed issues, but I cant reopen an issue only create new comments.

Comments

Shannon Deminick 17 Feb 2014, 05:05:14

Are these 2 separate clean installs or upgrades?


Peter Gregory 17 Feb 2014, 05:12:37

Both are upgrades 7.0.1 -> 7.0.3 and the other is 7.0.2 -> 7.0.3


Shannon Deminick 17 Feb 2014, 06:12:08

We've had issues with people's CDF not clearing correctly, can you please delete all your CDF cache and change the version number in the CDF config, see if that works.


Peter Gregory 17 Feb 2014, 07:35:47

Ahhh that fixed it thanks. i must remember to kill the CDF cache.


Shannon Deminick 17 Feb 2014, 08:13:32

It will be auto cleared in the future - the version actually gets incremented on upgrades but the old cache files remain, so people have had problems because they've started back at version #1 but already had old version #2 cache files there, so when it upgraded it tried using the already stale version #2 files. The new way will the hash code of the current datetime ticks, plus we'll auto-remove the old cache files.


Peter Gregory 17 Feb 2014, 09:10:14

You can close this unless there is something that you need to do to fix CDF so it doesnt happen again?


Shannon Deminick 17 Feb 2014, 09:24:32

yup it's closed


Priority: Major

Type: Bug

State: Closed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.0.3

Due in version:

Sprint:

Story Points:

Cycle: