U4-4447 - Image Cropper: Uploading does not populate image properties

Created by Asbjørn Riis-Knudsen 14 Mar 2014, 23:10:36 Updated by Shannon Deminick 20 Mar 2014, 02:14:15

Relates to: U4-4052

I created an Image Cropper data type and replaced the upload field with that. Given the fact that the cropper now includes an upload field, this seems to be the intended usage. When manually creating an image (right-click, Create), and then using the upload field in the image cropper, the other image properties (width, height, size etc.) are not populated. Interestingly, they are populated if using HTML5 drag and drop upload in a folder...

Comments

Asbjørn Riis-Knudsen 17 Mar 2014, 21:30:56

I have a fix for this working locally. I just need to test some more, will hopefully have a pull request tomorrow evening. One question: Is it required to be able to interchange the Upload and Image Cropper datatypes? Right now the Upload datatype won't work when changing from the Image Cropper datatype to the Upload Datatype (the reverse works).


Asbjørn Riis-Knudsen 18 Mar 2014, 21:41:14

A short update: On testing further, HTML5 upload is still broken. Will hopefully have a fix by tomorrow.


Asbjørn Riis-Knudsen 19 Mar 2014, 16:48:19

Here is a pull request that should work in every case: https://github.com/umbraco/Umbraco-CMS/pull/323


Priority: Normal

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Pull request

Affected versions: 7.1.0

Due in version: 7.1.0

Sprint:

Story Points:

Cycle: