U4-4634 - Image preview in Media is stretched

Created by Bjarne Fyrstenborg 07 Apr 2014, 22:24:01 Updated by Jeroen Breuer 11 Aug 2014, 14:20:22

Is duplicated by: U4-5089

Relates to: U4-4771

Relates to: U4-5304

Relates to: U4-5315

I uploaded a few images to the media section in v.7.1.0 and noticed that one of the image previews was stretched. The images in this example from top left have the following proportions (w x h):

  • 669 x 1000 px
  • 667 x 1000 px
  • 1000 x 698 px
  • 751 x 1000 px
  • 1000 x 751px (the stretched image in preview)

Furthermore I noticed that when I change the sort order - I move the last Image one up in sort order, go to a different view (e.g. for an image) and go back to the media "root" view, then no image previews are displayed. I then took a look in the console and saw the following error:

'''RangeError: Maximum call stack size exceeded'''

See attached screenshot.

It seems to be an issue depending how the images are sorted. In another sorting af all the images I got a more correct view, but in some cases the console displays the error or the image was stretched.

You could test with the attached images in Lightair.zip

Furthermore I am using Chrome Version 33.0 and the issue might depend on the screen resolution, so the screen resolution I am using is 1366 x 768

11 Attachments

Download Lightair.zip

Comments

Jeroen Breuer 23 Jul 2014, 07:42:36

Is there a workaround for this? Instead of a streched image I prefer the image to be the correct size and leave some whitespace instead.


Bjarne Fyrstenborg 05 Aug 2014, 21:50:23

It's also an issue with the preview in Media Picker. In the screenshot I have uploaded same Umbraco logo (200x200px) three times from the Media Picker.


Jeroen Breuer 08 Aug 2014, 12:09:02

More and more customers are starting to complain about the stretched images. We promise them a brand new CMS and all these streched images just look messy compared to the rest of the CMS. Any idea when we can expect a fix or just have all the images the same size like in v6 (see v6 attachment). The media picker also shows them stretched (see stretched attachment).


Asbjørn Riis-Knudsen 08 Aug 2014, 13:35:05

Yes, this is quite annoying. It looks very unprofessional. Why not display rows of thumbnails (like v6) instead of this fancy layout algorithm, which looks cool, but only works half of the time?


Jeroen Breuer 08 Aug 2014, 19:56:42

Wow that was a quick fix :) https://github.com/umbraco/Umbraco-CMS/commit/24a6ae4e327b42afce81c05948cfa1b2da2c085b


Asbjørn Riis-Knudsen 08 Aug 2014, 20:25:11

Thanks for the quick fix :) 7.1.5 is looking like a really nice release, it fixes a lot of little annoying things.


Jeroen Breuer 11 Aug 2014, 14:20:22

Just tested the latest nightly and it already looks a lot better now :-).


Priority: Normal

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.1.0, 7.1.1, 7.1.2, 7.1.3, 7.1.4

Due in version: 7.1.5

Sprint:

Story Points:

Cycle: