U4-4636 - The upload file editor does not create correct image thumbnails based on prevalues

Created by Andrew Swerlick 08 Apr 2014, 05:04:42 Updated by Sebastiaan Janssen 22 Aug 2014, 08:41:41

Relates to: U4-5385

The built in upload field control does not create thumbnails based on the prevalues provided by the user when editing the data type. The problem appears to be in the ImageHelper.GenerateMediaThumbnails method, line 54. Here the resize method is always called with "thumb" for the fileNameAddition parameter, making it so the image helper just keeps overwriting the same thumbnail, and not generating different ones.

Comments

Andrew Swerlick 08 Apr 2014, 05:14:15

Submitted fix with pull request https://github.com/umbraco/Umbraco-CMS/pull/349


Sebastiaan Janssen 29 May 2014, 16:22:47

Thanks for the pull request!


david whiteford 22 Aug 2014, 08:23:01

This isnt 100% fixed.

yes it creates the correct sizes now, however they are names like: "jellyfish_250x317.jpg" rather than "jellyfish_250_thumb.jpg" - as I believe it should be named - the current way of naming its useless as we would need to know exact dimensions rather than just the prevalue value!

Also, in the admin panel the prevalues are emptied when the Data Type is saved - meaning there is no reference as to what they were set as. And then removing one removes them all as they are all empty.


Priority: Normal

Type: Bug

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Pull request

Affected versions: 7.1.0, 7.1.1, 7.1.5

Due in version: 7.1.5

Sprint:

Story Points:

Cycle: