U4-4952 - RTE: macro editing - parameter dialog blank

Created by Gavin Faux 20 May 2014, 11:19:43 Updated by Sebastiaan Janssen 26 Oct 2014, 21:07:41

Is duplicated by: U4-4958

Is duplicated by: U4-4980

Is duplicated by: U4-5009

Is duplicated by: U4-5061

Is duplicated by: U4-5623

In 7.1.1 selection and editing of macros in the rich text editor was consistent. Switching between macros embedded in the RTE and editing via "Insert Macro" button brought up dialog with existing macro parameters; however in current build (7.1.3) dialog box is blank and therefore proving to be a major usability issue.

If I revert the dialog memory leak fix [in this commit|https://github.com/umbraco/Umbraco-CMS/commit/aa2375b8bab23116ed4ee97fac8dca64bea28b3f] previous behavior/usability is restored.

Is there any other workaround/more permanent fix to restore usability other than us reverting the code in our installation?

Thanks

3 Attachments

Download belle.zip

Comments

Shannon Deminick 21 May 2014, 01:15:06

In the meantime you'll need to revert that change, i'll fix today in code and 7.1.4 will be released soon


Shannon Deminick 21 May 2014, 01:38:50

It would seem that it's the 2nd time you try to launch the macro dialog that it's clear, the first time seems to work even with editing macros.


Shannon Deminick 21 May 2014, 05:26:13

Fixed in rev: 9f16bee040622652ef9f05276ba55f9684b74bb8


Sebastiaan Janssen 21 May 2014, 07:41:11

Until 7.1.4 is out, you can unzip the attached file into your ~/Umbraco folder. After that make sure to change the version in ClientDependency.config (just change the number to something else) so that you don't get a cached version.


Priority: Major

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.1.2, 7.1.3

Due in version: 7.1.4

Sprint:

Story Points:

Cycle: