U4-5093 - Can't get generic properties to publish

Created by Joel 16 Jun 2014, 07:14:12 Updated by Sebastiaan Janssen 16 Jun 2014, 08:35:57

I receive constant errors when attempting to publish a basic content page with only 3 generic properties. Errors are always in the format "pageTitle at Properties is not in a correct format" where pageTitle is my generic property. I'm getting this error in 4.11.10, 6.2.1 and 7.1.4!

All 3 generic properties are textstrings. The datatype is correct, and in developer, the datatype of textstring is still nvarchar. There is no regex in place when I setup the property in the document type.

Comments

Sebastiaan Janssen 16 Jun 2014, 08:35:02

I can't reproduce this, could you please explain in more detail how you are setting this up? Also have a look in App_Data\Logs\UmbracoTraceLog.txt to see if there's more detailed errors in there.

Steps I took to reproduce:

  • Start with a new 7.1.4 install that uses the Txt starter kit
  • Add a property on the home document type with an alias of pageTitle
  • Save & Publish the home page, without changing pageTitle (works)
  • Save & Publish the home page, changing pageTitle to "test" (works)


Sebastiaan Janssen 16 Jun 2014, 08:35:57

By the way, you should use ASP.NET 4.5 for v7 projects, that might be your problem (for example: Visual Studio 2010 doesn't support .NET 4.5)


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: