U4-5190 - Overwrite Media File in 6.2.1 - process cannot access

Created by Thomas Beckert 04 Jul 2014, 08:23:32 Updated by Shannon Deminick 10 Jul 2014, 01:48:27

When I create a Media-Node, e.g. an image,and after that, upload a new image with the same name in the same node, I got the error message:

"The process cannot access the file 'C:\xxxxxxxx.jpg' because it is being used by another process."

This means, that I cannot replace any image with a new one that has the same name.

Restart of the webpage or application pool did not solve the problem.

Deleting is working.

Comments

Shannon Deminick 08 Jul 2014, 06:58:15

Don't think this relates to the other issue at all but will investigate it. Are you doing anything out of the ordinary with your site that you have left out of the above details? (i.e. load balancing ?)


Thomas Beckert 08 Jul 2014, 07:08:13

Sorry, the relation was a mistake. I didn't want to relate this to any issue.

To your question: no, nothing out of the ordinary. No custom event handlers, load balancing or kind like this.


Shannon Deminick 10 Jul 2014, 01:16:00

Yup, i can replicate, fixing now.


Shannon Deminick 10 Jul 2014, 01:42:07

This is caused by un closed/un disposed streams. Have fixed this one among a few others.


Priority: Normal

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 6.0.0, 6.1.0, 7.0.0, 7.1.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.1.1, 6.0.6, 6.0.5, 6.0.7, 6.1.2, 6.1.3, 6.1.4, 6.1.5, 6.1.6, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.1.1, 7.1.2, 7.1.3, 7.1.4

Due in version: 7.1.5, 6.2.2

Sprint:

Story Points:

Cycle: