U4-5826 - Nuget Upgrade to 7.2.0 beta2 Update-Package : A numeric comparison was attempted on "$(TargetPlatformVersion)" that evaluates to ""

Created by Steve Morgan 17 Nov 2014, 18:17:59 Updated by Shannon Deminick 26 Jun 2017, 06:40:03

Tried to upgrade using Update-Package UmbracoCms -Version 7.2.0-beta2 -Pre

Output:

Updating 'UmbracoCms' from version '7.1.6' to '7.2.0-beta2' in project 'white-label-v-7-1-6'. Removing 'UmbracoCms 7.1.6' from white-label-v-7-1-6. Skipping 'config\applications.config' because it was modified. Skipping 'config\ClientDependency.config' because it was modified. Skipping 'config\Dashboard.config' because it was modified. Skipping 'config\trees.config' because it was modified. Skipping 'config\umbracoSettings.config' because it was modified. Skipping 'Web.config' because it was modified. Update-Package : A numeric comparison was attempted on "$(TargetPlatformVersion)" that evaluates to "" instead of a number, in condition "'$(TargetPlatformVersion)' > '8.0'". C:\Program Files (x86)\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets At line:1 char:1

  • Update-Package UmbracoCms -Version 7.2.0-beta2 -Pre
  •   + CategoryInfo          : NotSpecified: (:) [Update-Package], Exception
      + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.UpdatePackageCommand
    
    

I can send a copy of the project if required - steve@siempresolutions.co.uk

Comments

Steve Morgan 17 Nov 2014, 18:21:37

Version Visual Studio Ultimate 2013 - V12.0.031101.00 Update 4

Resharper not installed (as far as I know!)


Steve Morgan 18 Nov 2014, 10:58:01

Tried a few different things to recreate to see if I can narrow on the issue. Took vanilla clean builds of 7.1.6 and 7.1.8 and they upgraded fine. Added the packages and system.web.mvc etc web.config and dll changes to vanilla copies and they also went.

Went back to my original project after all of this - cleared the package cache as per http://docs.nuget.org/docs/release-notes/nuget-1.3 and it worked fine! Now can't recreate issue - suspect this is a nuget issue. If other users get this, roll the project back clear the nuget package cache and retry.


Shannon Deminick 26 Jun 2017, 06:40:03

Closing issue due to inactivity - see blog post for details https://umbraco.com/blog/issue-tracker-cleanup/


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: