U4-6172 - Context menu right click 'send to publish' appears to be broken. v7.2.1

Created by Lewis 22 Jan 2015, 17:02:36 Updated by Shannon Deminick 26 Jun 2017, 07:08:48

What did you do?

Fresh install of Umbraco 7.2.1 via nuget. Setup a user with 'Send to publish' permission. Right click any node in the tree and select 'Send to publish'

What did you expect to happen?

Panel with usual styling to slide out. Content marked as sent for approval. ContentService.SendingToPublish event fired and after ContentService.SentToPublish event fired.

What actually happened?

Oddly styled panel shown with loader that never completes. Console error: Uncaught ReferenceError: UmbClientMgr is not defined. Neither ContentService.SendingToPublish or ContentService.SentToPublish events fired. Content not marked as sent for approval.

Screenshots attached

2 Attachments

Comments

Andrew de Rozario 10 Mar 2015, 10:30:40

Hi,

I have experienced the same issue. I think it is related to the fact that the element that is being called is in an Iframe. If the markup is changed the in the link from onclick="javascript:UmbClientMgr.closeModalWindow();" to onclick="javascript:window.parent.UmbClientMgr.closeModalWindow();" clicking the link dismisses the dialog. The action is actually completed so the workaround is to refresh the window. Am fairly new to umb 7 so am not sure what would break is you were to change the markup.


Shannon Deminick 26 Jun 2017, 07:08:48

Closing issue due to inactivity - see blog post for details https://umbraco.com/blog/issue-tracker-cleanup/


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version:

Sprint:

Story Points:

Cycle: