U4-6412 - Backoffice breadcrumb gets confused

Created by Douglas Robar 17 Mar 2015, 10:36:02 Updated by Shannon Deminick 18 May 2015, 10:15:21

Is duplicated by: U4-6387

Is duplicated by: U4-6459

Is duplicated by: U4-6594

Is duplicated by: U4-6630

Relates to: U4-6387

Seen in 7.2.1 and 7.2.2

I don't know what triggers this behaviour and it seems inconsistent between content nodes. It does not seem to be related to hiding toplevel nodes from path (in web.config), nor with having cultures and hostnames assigned to multiple root nodes in the content tree, nor with some nodes being in ListView mode.

But at some point during the L1 course (rev 25 and rev26 workbooks, and certainly before the end of the second day) the breadcrumb gets confused.

The content tree is: Welcome > Documentation > FAQ > Lunch is making me... And the breadcrumb displays: FAQ > Lunch is making me... > Documentation > Welcome

Or in another case, the content tree is: Welcome > News > This should be first And the breadcrumb displays: Welcome > This should be first

In one case the sequence of items is incorrect and in another there are items missing from the breadcrumb.

2 Attachments

Comments

Andy Butland 25 Mar 2015, 20:56:45

I've submitted a PR for the out of sequence issue (also reported in the linked issue): https://github.com/umbraco/Umbraco-CMS/pull/662


Sebastiaan Janssen 25 Mar 2015, 20:59:10

Yay! Thanks Andy!


lesleyfa 18 May 2015, 10:07:13

This job assigned to Shannon Deminick nearly 8 weeks ago - any progress? Do you know when we can expect a fix?


Shannon Deminick 18 May 2015, 10:15:21

You can see that this issue has been assigned to 7.2.5, and it is marked as fixed... and 7.2.5 is released: https://our.umbraco.org/contribute/releases/725


Priority: Normal

Type: Bug

State: Fixed

Assignee: Shannon Deminick

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Pull request

Affected versions: 7.2.1, 7.2.2

Due in version: 7.2.5

Sprint:

Story Points:

Cycle: