U4-6552 - Cache file becomes corrupted sometimes when using "unpublish at": Oops: this document is published but is not in the cache (internal error)

Created by andrei 24 Apr 2015, 13:07:42 Updated by Shannon Deminick 26 Jun 2017, 07:11:21

Customer tested a sitemap implementation so he used some features like "unpublish at" and "umbracoNaviHide". Then when checking if sitemap shows some published nodes he discovers they are missing and when checking the item in umbraco under properties he gets this message (attachement):

Oops: this document is published but is not in the cache (internal error)

I can see this bug was fixed (U4-3145) in some older versions but now it's back.

1 Attachments

Comments

Mücahit GENÇ 24 Apr 2015, 15:56:44

Hi andrei,

http://umbraco.com/media/62660/WindowsLiveWriter_Dec5Sortbynameorcreatedate_13A64_dec5-result_2.png

try please after again publish


andrei 05 May 2015, 10:26:16

Hi Mücahit,

Yes, playing with publish\republish would probably fix it, but that's just a temporary workaround. Next time it comes up it could go unnoticed for a while.

That error should not come up in the first place.


Shannon Deminick 26 Jun 2017, 07:11:22

Closing issue due to inactivity - see blog post for details https://umbraco.com/blog/issue-tracker-cleanup/


Priority: Critical

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.2.4

Due in version:

Sprint:

Story Points:

Cycle: