U4-6854 - Grid editor - insert control: Make blue area clickable

Created by Bjarne Fyrstenborg 19 Jul 2015, 15:18:08 Updated by Bjarne Fyrstenborg 30 Dec 2015, 02:23:15

Relates to: CON-804

When inserting a new control the and hovering a type in the dialog the background color is changed to blue on hover - however not the entire blue area is clickable. E.g. if one click on the edges or a small area between the icon and the text nothing happens.

Maybe change the anchor to display:block and set ng-click on the

  • or move the padding on
  • to the element.

    Comments

    Bjarne Fyrstenborg 21 Oct 2015, 10:19:26

    Also make sure that this is fixed in the new Content Type Editor for Umbraco 7.4 (I checked the latest changes in the dev-v7-contenttypeeditor branch). Furthemore it is the same issue for Umbraco Forms: http://issues.umbraco.org/issue/CON-804 So ensure it is consistent throughout the UI.


    Bjarne Fyrstenborg 17 Dec 2015, 22:18:33

    This also apply to Umbraco 7.4.0-beta, even the grid has changed since 7.3.x


    Simon Busborg 22 Dec 2015, 19:06:53

    PR: https://github.com/umbraco/Umbraco-CMS/pull/978


    Bjarne Fyrstenborg 30 Dec 2015, 02:22:58

    @simonbusborg can you ensure the changes it added to Umbraco Forms as well? With the latest changes in UmbracoCms.7.4.0-nightly134 the grid "add"-dialog (new styling) is different from Umbraco Forms (UmbracoForms.Package.4.1.4). http://issues.umbraco.org/issue/CON-804

    Maybe Umbraco Forms should just inherit the styles from Umbraco Core to make it consistent and only overwrite where necessary.


  • Priority: Normal

    Type: Bug

    State: Fixed

    Assignee:

    Difficulty: Normal

    Category:

    Backwards Compatible: True

    Fix Submitted:

    Affected versions: 7.3.0, 7.4.0, 7.2.8

    Due in version: 7.4.0

    Sprint: Sprint 5

    Story Points:

    Cycle: