U4-6939 - 'html code' button is missing in the Rich Text Editor

Created by Tom Van Rompaey 10 Aug 2015, 11:32:19 Updated by Sebastiaan Janssen 19 Aug 2015, 16:40:12

Is duplicated by: U4-6954

Is duplicated by: U4-6984

What did you do? Wanted to use the html editor in the Rich Text Editor in 7.3.0 beta2 and beta3.

What did you expect to happen? Use the html editor in the Rich Text Editor.

What actually happened? There's no 'html code' button in the toolbar

2 Attachments

Comments

Sebastiaan Janssen 10 Aug 2015, 11:37:45

I can't reproduce this actually, is this an upgrade from an older version of Umbraco or a fresh install?

Do you have any javascript errors?


Tom Van Rompaey 10 Aug 2015, 11:42:34

It's a fresh install. I noticed it in a fresh install of beta3 and then I also took a look at an older fresh test install of beta2. I have no javascript errors.


Sebastiaan Janssen 10 Aug 2015, 11:57:04

Cool, I can repro now (couldn't on an upgraded site).


Asbjørn Riis-Knudsen 17 Aug 2015, 09:36:12

The configuration for the codemirror button in tinyMceConfig.config is wrong, which causes the button to vanish: code images/editor/code.gif code 1

frontendcommand should be "codemirror" and not "code"

NOTE: This change will cause the code button to become deselected in the RTE datatype settings, so some sort of migration is probably needed, as well as updated defaults.


Rik Helsen 18 Aug 2015, 12:40:06

I have same issue


Sebastiaan Janssen 19 Aug 2015, 16:40:12

Commit made by '''Sebastiaan Janssen''' on ''2015-08-19T18:40:04+02:00'' https://github.com/umbraco/Umbraco-CMS/commit/4ec63ffd0dd9a1204e3ef43ce183b82bd72741fc

U4-6939 'html code' button is missing in the Rich Text Editor]

#U4-6939 Fixed


Priority: Normal

Type: Bug

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.3.0

Due in version: 7.3.0

Sprint:

Story Points:

Cycle: