U4-6957 - Problem with AutoMapper and external packages

Created by Andy Butland 13 Aug 2015, 11:02:51 Updated by Sebastiaan Janssen 13 Aug 2015, 11:41:48

Relates to: U4-6923

Based on comments on the forum - https://our.umbraco.org/forum/ourumb-dev-forum/bugs/64394-Reference-to-Specific-Version-AutoMapper-causing-downstream-issues - I think that you've picked this up, but couldn't see an issue here so wanted to make sure. Or see if there's a solution!

But the issue is that with the beta of 7.3, Umbraco core has a NuGet dependency on Automapper 3.3.1 or above. This causes an issue with packages built against 3.0.0: "Could not load file or assembly 'AutoMapper, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.". Archetype is one example.

I haven't been able to find a way to fix this with binding redirects, so looks like you would need to revert the dependency back to 3.0.0 as was the case for version 7.2.8 to resolve this without a breaking change?

Comments

Sebastiaan Janssen 13 Aug 2015, 11:40:46

Yup, we've reverted to 3.0.0 in 7.3.0 final.


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.3.0

Due in version:

Sprint:

Story Points:

Cycle: