U4-7373 - Error notifications shown are hidden underneath the dialogs

Created by Shannon Deminick 09 Nov 2015, 16:41:33 Updated by Shannon Deminick 15 Dec 2015, 09:54:40

An example is the copy/move dialogs, if there is an error and we show error notifications, they are hidden behind the dialog.

@madsrasmussen btw, I've fixed up the copy/media controllers to show the error notifications since this was missing... which is how I found this issue. To test you can just try copying a node to itself.

2 Attachments

Comments

Per Olsson 08 Dec 2015, 09:46:26

Has this already been fixed because I'm not able to reproduce in 7.3.1 (Chrome)? I tried to Copy a node over itself and I get an error, but not hidden nor underneath.

Because error notifications are mentioned too (notificationsService?), in the included image there is a notification too, though not an error but info, but still not underneath the dialog.


Simon Busborg 15 Dec 2015, 09:28:32

PR: https://github.com/umbraco/Umbraco-CMS/pull/950

How to test: Try to move a node(content) under another node(content) where it isn't allowed, a notification bar will be displayed, this should now be on top of everything and match the width of the main content.


Per Olsson 15 Dec 2015, 09:43:01

@simonbusborg not to be picky, but any particular reason the error message ("Failed to move content") no longer has the red box with white text but no box and red text instead (compare your image with mine)?


Shannon Deminick 15 Dec 2015, 09:47:00

@polsson because it was never meant to be that way in the first place. Alert boxes are no longer the way that we display error/warning messages.


Per Olsson 15 Dec 2015, 09:49:55

Thanks for the clarification Shannon.


Shannon Deminick 15 Dec 2015, 09:54:36

@simonbusborg works great, closing issue.


Priority: Normal

Type: Bug

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version: 7.4.0

Sprint: Sprint 5

Story Points:

Cycle: