U4-7669 - Update Newtonsoft.Json dependency to v8.0.1 from v6.0.5

Created by Jeavon Leopold 07 Jan 2016, 19:17:28 Updated by Jeavon Leopold 10 Feb 2016, 12:24:43

Many NuGet packages already have minimum dependencies of Newtonsoft.Json > 7 and therefore are not currently compatible with Umbraco so it would be great to get this dependency updated. Updating to v8.0.1 adds assembly redirect as it has done before and it seems everything in Umbraco is happy. Would be great in Umbraco v7.4 but that's probably wishful thinking :)

Comments

Jeavon Leopold 29 Jan 2016, 12:53:28

@sebastiaan we have been running with v8.0.1 for almost a month now without discovering any isses


Sebastiaan Janssen 01 Feb 2016, 08:26:27

I'll loosen it up in the nuspec so you can at least install it without errors.


Sebastiaan Janssen 01 Feb 2016, 08:28:34

Commit made by '''Sebastiaan Janssen''' on ''2016-02-01T09:28:20+01:00'' https://github.com/umbraco/Umbraco-CMS/commit/924d2a0d889a3702b9b31593e500331abae3f7bf

U4-7669 Update Newtonsoft.Json dependency to v8.0.1 from v6.0.5

#U4-7669 Fixed


Jeavon Leopold 01 Feb 2016, 10:17:29

Thanks @sebastiaan


Jeavon Leopold 10 Feb 2016, 11:47:26

@sebastiaan Looks like you have the dependency on UmbracoCms also https://github.com/umbraco/Umbraco-CMS/blob/924d2a0d889a3702b9b31593e500331abae3f7bf/build/NuSpecs/UmbracoCms.nuspec#L19


Sebastiaan Janssen 10 Feb 2016, 12:05:01

Oh shoot! All fixed now, thanks!


Jeavon Leopold 10 Feb 2016, 12:18:49

Cool, not sure why you need the dependency on UmbracoCms as you have it on UmbracoCms.Core?


Sebastiaan Janssen 10 Feb 2016, 12:22:58

Yeah, I'll need to retrace my steps there, think it's something to do with earlier json.net install problems we had. Now I'm scared to touch it.. ;-)


Jeavon Leopold 10 Feb 2016, 12:24:43

ah well, does no harm as long as they are the same :)


Priority: Normal

Type: Feature (request)

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.2.8, 7.3.1, 7.3.2, 7.3.3, 7.3.4

Due in version: 7.4.0

Sprint:

Story Points:

Cycle: