U4-7917 - Umbraco updated from 7.3.0 to 7.3.7 - Section Navigation bar requires double click to traverse and Initial section remains active.

Created by Tom Chance 08 Feb 2016, 15:52:59 Updated by Tom Chance 09 Feb 2016, 11:23:22

Updated a "Base" installation from 7.3.0 to 7.3.7, The base installation is pure Umbraco with no edits to the Backoffice CMS.

When attempting to view different sections, It requires a double click to traverse from Content to Media for example. Once in the Media section, the content section still highlights as the active item in this Nav.

This seems to be the case with all sections. Below I have placed a Javascript / Angular looking error that appears in the chrome debugger:

TypeError: Cannot read property 'alias' of undefined at Object.scope.sectionClick (umbraco.directives.js?cdv=812089736:2524) at angular.min.js?cdv=812089736:74 at angular-mobile.js?cdv=812089736:270 at Object.e.$eval (angular.min.js?cdv=812089736:92) at Object.e.$apply (angular.min.js?cdv=812089736:92) at HTMLAnchorElement. (angular-mobile.js?cdv=812089736:269) at HTMLAnchorElement.x.event.dispatch (jquery.min.js?cdv=812089736:5) at HTMLAnchorElement.y.handle (jquery.min.js?cdv=812089736:5)

Screenshot attached to show more clearly.

1 Attachments

Comments

Sebastiaan Janssen 08 Feb 2016, 20:00:54

This is most likely a cache problem. Make sure to change the version in your ClientDependency.config file (just make it 1 higher or lower) and thoroughly clear your browser cache.


Tom Chance 09 Feb 2016, 11:23:22

@sebastiaan Hi Sebastiaan, My apologies - I had incremented the ClientDependency config file after the update but did not completely clear browser cache (Just Ctrl'ed F5). All is working! Thank you for your time.


Priority: Normal

Type: Bug

State: Can't Reproduce

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.3.7

Due in version:

Sprint:

Story Points:

Cycle: