U4-8016 - Pick only images from media

Created by Sebastiaan Janssen 17 Feb 2016, 15:42:16 Updated by Sebastiaan Janssen 02 May 2016, 06:25:55

Relates to: U4-8034

Relates to: U4-8331

Relates to: U4-8391

Due to a merge problem in http://issues.umbraco.org/issue/U4-7727 this feature was never fully implemented. See comments in U4-7727 for the fix.

2 Attachments

Comments

Bjarne Fyrstenborg 17 Feb 2016, 19:45:56

It seems not to have affected Umbraco 7.3.7 and 7.3.8, but only Umbraco 7.4.0 and 7.4.1

The "only images" property was added to "multiple media picker" from Umbraco 7.3.7 and it seems to work fine in 7.3.7 and 7.3.8


Sebastiaan Janssen 08 Mar 2016, 13:48:35

Try as I might, just adding onlyImages: onlyImages, didn't help, I also compared between 7.3 and 7.4 and see no obvious problems. I'll re-assign to @madsrasmussen to have a look.


Mads Rasmussen 08 Mar 2016, 19:58:33

PR: https://github.com/umbraco/Umbraco-CMS/pull/1158


Asbjørn Riis-Knudsen 30 Mar 2016, 09:01:42

@sebastiaan Why is this marked as fixed? The PR was never merged and the functionality is still broken in 7.4.2.


Sebastiaan Janssen 30 Mar 2016, 10:56:51

Weird, must have forgotten to merge or something.. :o


Asbjørn Riis-Knudsen 30 Mar 2016, 12:27:07

@sebastiaan Thanks :) Could you perhaps take U4-8034 as well? These two sort of go together...


Sebastiaan Janssen 30 Mar 2016, 12:46:14

I'll have a look while doing this one


Warren Buckley 01 Apr 2016, 12:55:26

Setting this as Fixed. Reviewed the code & ensured the functionality works as described, merged in!


Glenn Lieberman 14 Apr 2016, 19:24:07

@sebastiaan @warren.buckley I am still experiencing this bug after upgrading .sln from 7.4.2-->7.4.3. I have bumped my clientdependency # up and I have Chrome Dev Tools open with 'Disable JS cache', and CTRL+F5'd As best I can tell(SVN DIFF), my local files are updated with the committed changes. I can confirm that my data type is using 'MultipleMediaPicker' and has 'Pick only images' checked, but not 'Pick multiple items'. I have tested validation of: -my existing property -adding a new property that uses that datatype. -adding a new property that uses a new datatype configured with 'MultipleMediaPicker' and 'Pick only images' checked. All cases allow me to save a media folder.


Asbjørn Riis-Knudsen 14 Apr 2016, 19:28:39

From what I understand, this patch only deals with files (it looks at the file extension). So it makes sense that you can still save a media folder. I actually think that the setting to allow selection of media folders should be independent of Only images, so maybe open a new issue for that?


Glenn Lieberman 14 Apr 2016, 21:06:31

Ahh, looks like you are correct. I can confirm now that the 'pick only images' setting filters out non-images from the picker, which ostensibly it would not have before I upgraded to 7.4.3. I can get a PDF to show/hide from the picker options. I agree, I'll open a new issue. If I want images only selected then that means not folders also.


Darren Ferguson 22 Apr 2016, 12:04:29

@warren.buckley @sebastiaan as per screenshots - when you upload a PDF the media picker tries to create thumbnail of it - which returns a broken image. should i open a separate issue for this?


Sebastiaan Janssen 02 May 2016, 06:25:55

@darrenjferguson Always :-)

Created http://issues.umbraco.org/issue/U4-8391


Priority: Normal

Type: Bug

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted: Inline code

Affected versions: 7.4.0, 7.4.1

Due in version: 7.4.3

Sprint: Sprint 12

Story Points:

Cycle: