U4-8752 - NuGet upgrade to 7.5 beta 2 Client Dependency discrepancies

Created by John Churchley 20 Jul 2016, 13:45:03 Updated by Shannon Deminick 29 Jun 2017, 05:50:29

What did you do? Tried to upgrade a Umbraco Web Project which contains assemblies which only reference UmbracoCMS.Core

What actually happened? Install failed. Rolling back... update-package : Unable to uninstall 'ClientDependency 1.9.0-beta4' because 'ClientDependency-Mvc5 1.8.0.0' depends on it. At line:1 char:1

  • update-package UmbracoCMS -pre
  •   + CategoryInfo          : NotSpecified: (:) [Update-Package], Exception
      + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.UpdatePackageCommand
    
    

Comments

Shannon Deminick 29 Jun 2017, 05:50:29

Closing this since Nuget installation definitely works (may have been a beta issue)


Priority: Normal

Type: Bug

State: Closed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions: 7.5.0

Due in version:

Sprint:

Story Points:

Cycle: