U4-9887 - Uses new OUR endpoint for package installation

Created by Shannon Deminick 10 May 2017, 04:15:59 Updated by Mikkel Holck Madsen 15 May 2017, 09:49:50

Subtask of: U4-9609

Your report will have a greater chance of being addressed if you can give us clear steps to reproduce the issue, please answer the following questions in as much detail as possible: What did you do?

What did you expect to happen?

What actually happened?

Comments

Shannon Deminick 10 May 2017, 04:18:44

This has already been committed in bed5f8a03be9eae9f5c10077329d312de32ba5e6 and backported from 7.6 but it should be tested that this all works as expected:

  • New install, ensure that starter kits install
  • Ensure that packages install in the back office
  • Ensure that the correct version of packages gets installed - to test this, try to install Umbraco Forms via the packager in the back office, you should not get Forms 6.0.0 since it's not compatible with 7.5.x
  • Ensure that on a new installation when you use the Forms installer/dashboard in the forms section that you don't get forms 6.0.0 since that is not compatible with 7.5.x


Mikkel Holck Madsen 10 May 2017, 20:37:39

Fresh from source, dev-v7 ive openede the backoffice, and found Forms.

It's not able to find the package. Trying to figure out what it is calling, it is this endpoint: https://our.umbraco.org/webapi/packages/v1/cd44cf39-3d71-4c19-b6ee-948e1faf0525?version=7.5.13, which is "This package is not compatible with the Umbraco version 7.5.13".

So either the search in the backoffice is returning the wrong id for the Forms package, or the endpoint is verifying something wrongly.

this is the url it ends up calling: https://our.umbraco.org/webapi/packages/v1?pageIndex=0&pageSize=24&category=&query=forms&order=Default&version=7.5.13


Mikkel Holck Madsen 10 May 2017, 20:39:07

It looks like the issue comes from the results comming from Our though.


Mikkel Holck Madsen 10 May 2017, 20:40:00

It kinda related to this issue: CON-1350


Shannon Deminick 11 May 2017, 04:21:28

I've pushed an update to OUR should be working now


Mikkel Holck Madsen 15 May 2017, 09:49:46

Works like a charm, needed a few fixes on Our, but that has been taken well care of


Priority: Task - Pri 1

Type: Task

State: Fixed

Assignee:

Difficulty: Normal

Category:

Backwards Compatible: True

Fix Submitted:

Affected versions:

Due in version: 7.5.14

Sprint:

Story Points:

Cycle: